Suggestion: Rename "From Current Date" to "After Completed"

It took a while until I’ve realized that the Repeat Mode “From Current Date” sets the due date of the next iteration based on the date of completion, even though this was a feature I was explicitly looking for.

I recommend renaming it to something which refers to the fact that the next interval will start when the task is completed. My suggestion is “After Completed”

Agreed, should be an easy change. Will take a look, but if you want to send a pr for it, I’ll happily merge it.

This is now fixed in 6e759b3bee, please check with the next unstable build (should be ready for deployment in ~45min, also on try).