Saved Filters Option: "Include Tasks which don't have a value set" is still set after saving the filter despite the option was unselected

Hi,
I am trying to generate a view/saved filter where only task show up which are due today. This is really simple with your implementation of saved filters! Thumps up!

Although, when I select due date “now” from the filter, also the task which dont have a set due date show up. For some this might be a feature for me it is not as not scheduled task might not be due today.

I was hoping by unticking the box “Include Tasks which don’t have a value set” that these tasks (without a set due date) would not show up in the filtered output. Now, after unselecting the tick box I save the filter. But when I reopen the filter configure view again the box is selected again. The tasks without a set due date are still visible in the filtered output. Is this a bug that the box is not unselected?

If I misunderstood the meaning of the tick box “Include Tasks which don’t have a value set”, maybe someone can clarify?

Many Thanks!

This might be a bug in the save loic. Does it work when you create a new filter with the box unchecked?

Hi,
yes, you are right. It does work with a new filter! Thank you!

Just to add to your hypothesis: I have created the filter with the unchecked box. Now, when I try to change the filter settings, I the box status is not saved.

I really like your project! Keep up the good work. Hope I can help to identify possible other bugs in the future.

1 Like

Should be fixed in 13157e3bba - please check the next unstable build if the problem really went away.