Filter setting(s)

Yesterday I created a filter under Projects (which is also displayed on the left-hand side) The aim of the filter is to display all tasks for today and the overdue tasks. This also worked yesterday. When I opened the filter again today, it only showed me the overdue tasks. It seems that the “now/d” command is not dynamic. Today I created a list with the same settings and with the new list I see the tasks that are due today. → I would not need this filter if my settings were saved under “Upcoming”

Can you reproduce this on try?

I created something but I found a mistake on my side and (I assume) on Vikunja’s side.
Attaced you see the settings from my cloud.vikunja.
It is super clumpy to change the field from a date to a string, but anyway.
My mistake was that I didn’t use now/d+1d - I just use now/d. But it is still strange that I saw all Tasks, also from the same day, when created the FIlter in cloud.vikunja.
Screenshot 2023-11-14 210936

On try.vikunja and in cloud.vikunja it is not possible to write now/d+1d. As soon as I type the “+” the edit field converts the sting into a date.

That sounds like a bug. I’ll take a look.

Should be fixed in aa5e11915e - pleae check with the next unstable build in ~30min on try if the problem really went away.

The input is fixed. Very good. Now you can enter now/d+… can be entered. With restriction, see below.
Whether the “now” is dynamic or static I can check tomorrow.

New bug I:
If I set the date as in the screenshot, enter the date manually (without selection via the calendar), and then go to the second Edith field, Vikunja crashes.
At the point shown in the screenshot.

Nwuer Bug II:
When selecting a date range (start and stop) date via the calendar view, Vikunja crashes.

Further suggestions for improvement:

  1. Enter the (start or end) date directly in the edit field. This is currently not possible. I will provide a more detailed description when the bug(s) have been fixed.
  2. It seems to be practical to select a start and end date in the calendar at the same time. But it is totally impractical if you only want to select one date. Just the start date or just the end date. This is currently not possible.
    Use case: I want to enter the end date now/d+1d for all tasks and enter 01.01.2000 as the start date via the calendar. This is not possible. Incidentally, this date cannot be entered manually and must be entered via the calendar.
    Once a date has been entered, it can only be adjusted via the calendar. Any typing in the Edith field leads to strange results.

Screenshot 2023-11-18 130710

There is now a workaround in place to prevent the two bugs from happening (602d15985b). Please note, everything related to filters is maintenance-only until the new filter syntax is done.

From - to is not taken over.
Even if a period has been selected in the calendar, see screenshot.
If you then click on “Select date range” again, you will see the period in the calendar, but this is not transferred to the Edith field.


Could be that I created the task with EN language settings and edited it with german language settings.

switching back to EN allows me to enter:

But here the filter is not saved an I get the feedback (red banner):
Invalid task filter value.

creating a new filter with german language doesen’t support entering the date via the calender view

Is this still a problem in the current unstable build? (check on try)

Note that filters now work differently than what you might expect.

Wow. Query looks really good. It seems to have a lot of potential once it’s rolled out.
I’ll take another look at it in a few days.
Here’s what I’ve noticed on the try server (I haven’t tried more than the following):

dueDate accepts “<”, but not “<=”.
So I tried dueDate < now || dueDate = now/d+1d.

However, this command is not accepted by the server and is not saved.

I also noticed that the text entered in the description text field is written at the top right.
A field message also appears when I want to save the filter.

But as I said, the query looks good. Please ping me again when it has been further developed and I will be happy to take a closer look at the details.

Trying to use any of the date fields twice in a query (e.g. (dueDate > 'now/d+1d' && dueDate < 'now/d+7d') results in an error like: handler/ReadAllWeb 8850 no such column: dueDate. This doesn’t happen when using another field, e.g. assignee.

Version: v0.23.0+425-cc6801c5b1

@Marcel86 @taskmaster The bugs you’re describing should now be fixed. Please check with the next unstable build (~45min) or on try again.