Cannot pull docker unstable images from docker hub

Just discovered Vikunja. The project seems very promising. Good work!

Trying to pull unstable version of both api and front image does not work. While the tag is available on dockerhub, the image does not seem to be there (manifest missing).


What architecture are you trying to pull the image from?

I am on AMD64. Note that pulling form :latest work like a charm.

Right … pulling vikunja/api:unstable-linux-amd64 works perfectly.
Sorry for the noise.

Pulling vikunja/api:unstable works fine for me on amd64. What error message do you get?

Note that vikunja/api:unstable-linux-amd64 is likely outdated.

docker pull vikunja/api:unstable
Error response from daemon: manifest for vikunja/api:unstable not found

Could very well be because I am running an exotic distribution (Alpine Linux on musl).

Running a docker info gives me the proper os/archi combo (OSType: linux
Architecture: x86_64). Not sure why it does not select the proper image.
I’ll dig a little more later and update accordingly. (I should be able to force the selection anyway using --platform flag)

Thanks for your response anyway. (and for Vikunja!)

Fixed it! I was lagging far behind regarding Dockerd and Docker.
A good upgrade and I can now fetch :unstable and get the image for my arch.

Having now the same version as in, I though I would be able to setup the background for my lists using unsplash. But the option is not available. Any config I should do to enable unsplash (I could not find it).


Glad it works now!

Check out the default config file for unsplash configuration: api/config.yml.sample at main - api - Gitea

1 Like

Thanks! (I should have started with the config file indeed …)