Vikunja-desktop and Kanban 401 error

If the Vikunja-desktop has been running for more than a day or two without restarting, no new task can be created in Kanban mode, a 401 error occurs. Screenshot below

image

Can you do anything else? (View a list, create a list, create a task from one of the other views, etc…)

It normally logs you out within a day - get the same type of issue using it as a PWA. In fact this is why I stopped using desktop and just use Vikunja as a PWA - it remembers my username and password using standard browser autofill.

With desktop you have to manually log in every day…

I’m even into the habit of logging out at the end of the day so I mostly avoid this sort of error.

@cidace4928 try logging out and in again.

@kolaente Is there an env var to make sessions last longer?

Edit: I suppose the problem is that the frontend doesn’t realise the session has expired? It ought to detect that and bump the user back to the login page.

It should only log you out if you’re not actively using it within three days (each token is valid for three days by default). If you use it before it is due to expire, the frontend will automatically replace it with a new one. It will only request a new token once the current one is almost expired - maybe that threshold could be extended.

You can change the default ttl of the config in the server config: Config options | Vikunja (but I think this didn’t land yet in the stable version).

The next release will have a “remember me” option which will keep you logged in for 30 days while inactive.

1 Like

Ah. It’s possible my ‘next day’ impression was working day based - needed to log in on Monday after not touching it all weekend :slight_smile:

yes, i can change view type, create new task in list mode as sample. Also after doing this i can create new tasks in kanban mode again, without errors.

Or rather, the error as in my first message is displayed, but a new task can now be created