Filtering by label UX issues

When filtering by label like label = T it seems to autocomplete directly for the first possible match. When you want to continue writing a label name like “Test” then it appends the “est” at the autocompleted label and this results in a undefined label.

Additionally, there are issues when auto completing that every second label in a series of labels labels = X || labels = Y gets autocompleted to undefined, no matter what I do.

Is that reproducible on Https://try.vikunja.io?

Yeah, it’s also reproducible there

I was unable to reproduce this on try, using these steps:

Can you clarify what does not work for you? Maybe using a screen recording?

1 Like

Here, I tried this on the demo instance. I tried to enter labels in test but when I enter the first t, it automatically jumps to the full thing, adding est breaks it.

labelsBug

Thanks for the video. I’ll take a look.

This should be fixed in 68d233684f, please check with the next unstable build (should be ready for deployment in ~45min, also on try).

1 Like

Thanks a lot! This already works a lot better now :slight_smile:

I still saw some issues when adding multiple chained labels, I’ll show with another gif which should be the easiest way to explain. After saving pretty much all but the one are listed as undefined. I tested it on try.
labelsBug