Exec format error when running v0.18.1-linux-amd64-full


I’m trying to install Vikunja onto a Linux Ubuntu server without using Docker. Unfortunately after downloading the latest executable (vikunja-v0.18.1-linux-amd64-full) and trying to run it I get the following error message (already did chmod +x):

root@localhost:/opt/vikunja# ./vikunja-v0.18.1-linux-amd64-full
-bash: ./vikunja-v0.18.1-linux-amd64-full: cannot execute binary file: Exec format error

I’ve tried a few other binaries like 386-full, none of them worked.

Any suggestions?


What architecture are you trying to run this on?

Processor and kernel are both x64. I’ve got an Intel Xeon (E-2224G) processor, and the Linux kernel is also x64.

I think I found the issue: The file you’re downloading is a zip file, not an executable. It’s just missing the .zip ending. Not sure why that’s the case but it should work if you unzip it and then run the binary from the archive.

This is also explained here: Install Backend | Vikunja

Oh, interesting. Yeah unzipping it did the trick! Thanks for the help!

Seeing there was no zip extension I presumed it wasn’t zipped and that the docs were simply outdated or something.