Installing Vikunja on Ubuntu 22.04 without Docker

Hey guys,

So i’ve installed Vikunja on my machine without the use of Docker, with the help of the official docs.
For the past 2 days i can’t get it up and running, and i’m not finding anything regarding my error

image

My config : (Ubuntu 22.04 - Nginx - MariaDB - UFW)

My backend conf file : /opt/vikunja/config.yml

My frontend index.html : /var/www/vikunja/index.html

My Nginx conf file : /etc/nginx/sites-available/vikunja.conf

server {
    listen       80;
    server_name  vikunja.goldenhourmc.net;

    location / {
        root   /var/www/vikunja;
        try_files $uri $uri/ /;
        index  index.html index.htm;
    }

    location ~* ^/(api|dav|\.well-known)/ {
        proxy_pass http://localhost:3456;
        client_max_body_size 20M;
    }
}

Can someone please help me solve this. Thank you

The api is not reachable. Is the api up and running? And reachable for nginx locally on port 3456?

You also have set the language to the literal string “”. That’s not a valid language and probably the cause for the error.

The sample config is meant as a starting point and documentation. You should remove or comment out everything that you didn’t customize.

Ok so, i’m sorry for being a total noob but

  • I’ve tried curl http://localhost:3456/api/v1 but it returned : curl: (7) Failed to connect to localhost port 3456 after 0 ms: Connection refused

  • I’ve opened the port 3456 on UFW

  • I’ve set the language: "en" in the defaultsettings: part, if that’s what you mean ?

  • vikunja.service seems not able to start ?

● vikunja.service - Vikunja
     Loaded: loaded (/etc/systemd/system/vikunja.service; enabled; vendor preset: enabled)
     Active: activating (auto-restart) (Result: exit-code) since Tue 2023-11-28 11:42:48 UTC; 415ms ago
    Process: 421938 ExecStart=/usr/bin/vikunja (code=exited, status=203/EXEC)
   Main PID: 421938 (code=exited, status=203/EXEC)
        CPU: 1ms

I don’t know what to comment out from the file ?

again sorry these might be dumb questions, but i’m really lost here

That sounds like the cause of the problem. Try journalctl -u vikunja.service to view the logs of the service and figure out what went wrong.

Once the service is up and running, you can check it by going to <your-url>/api/v1/info - if that returns a json response similar to this one it should work fine.

Since you’re using nginx as a proxy you might not need ufw (I don’t know enough about it to be sure) as long as nginx can reach Vikunja locally.

Ok so turns out i used the wrong Vikunja package for my system.

I used the vikunja-v0.21.0-linux-amd64-full.zip instead of vikunja-0.21.0-amd64.deb.

Thanks for the tool and the support, @kolaente much appreciated :+1: