Issues with frontend (can't open settings, delete list, etc...)

Hi there again,

I’ve successfully got the frontend running and the backend installed, but something isn’t right. I can register, log in, create namespaces, task lists, and even tasks, but things just look and respond differently than on the demo (

Issues I’m having:

  • Originally the overview was empty, but reinstalling the frontend fixed it,
  • Can’t open the profile settings,
  • When I click on about the API version is empty,
  • I can’t delete task lists (the menu doesn’t exist).

Frontend version: 0.18.2 (latest).
Backend version: 0.18.1 (latest).

Using backend with a reverse proxy (NGINX).

When I try to open the settings page I get a tone of Javascript errors, which I don’t get in the demo (where it works normally).

Attached is an image showing the settings not appearing.

I would greatly appreciate some suggestions on how to get this otherwise awesome app working.



That sounds like the frontend is unable to see the api. Are you using this nginx config?

From the browser you’re accessing the frontend, can you access the api at /api/v1/info?

The /api/v1/info page came up as 404 page not found, which confirmed your idea.

I double-checked the Nginx config, I only found one variation: I had the proxy pass set to instead of localhost (because I prefer the IP over a name that still has to be resolved).

I changed the proxy_pass to localhost to match the config 100% and that solved the issue…

Don’t quite get how localhost works better than but ok. :slight_smile: Everything works now as expected.

Thanks once again for the help!

Glad it works now! I think the localhost setting might have something to do with the interface the vikunja api service is bound to. By default, that’s which essentially means all interfaces. Maybe nginx only looks for services bound to explicitly when you specify it like that?

I don’t know because I have another service running that is also bound to and Nginx finds it no problem with proxy_pass That’s also why I originally set it to, because I had experience with it working fine like that.