After fresh install, only access to the login page, with red empty box under the form buttons


I just installed the back-end and the front-end on my Linux server (Ubuntu 18.04). But, on the login page, when I attempted to register a new account, a red empty box appeared under the form buttons (and stays there ahah), and nothing else happened. How to know if the back-end is correctly installed? Maybe there are some prerequisites missing…? Is there someone who could help me out with this please?

Thanks a lot in advance!


How is it set up? With a reverse proxy? Otherwise you’ll probably need to configure the API URL in the frontend.

For debugging, what requests happen when you try to register? (Observable with the browser Dev tools, network tab)


No reverse proxy. But, a 404 error happens (this page either doesn’t exist or…) related to chunk-vendors.cd46555d.js:36. Do you know what I should do?

Did you configure the API URL?

Yes, well, I think so, according to what I understood from it.

`	// This variable points the frontend to the api.
// It has to be the full url, including the last /api/v1 part and port.
// You can change this if your api is not reachable on the same port as the frontend.
window.API_URL = ''
//</script><script src="/js/chunk-vendors.cd46555d.js"></script><script src="/js/app.bfb8db95.js"></script></body></html>`

You should add the protocol (https:// in your case):

window.API_URL = ''

Also I checked your site and it seems like Vikunja is not reachable from the outside. You need to either make sure the port 3456 is reachable from the outside or use a reverse proxy.
If you leave Vikunja running on the default port, you’ll also need to include that in the API Url configured in the frontend - this would then be in your case.

Hi again!

First, thanks a lot for taking the time to help me. Much appreciated!

Second, I changed the API Url for “” and I also created a rule in the server firewall to accept all incoming requests for the port 3456 (TCP and UDP). However, unfortunately, I still get the same red empty box when I try to register. :confused:

It looks like the Vikunja API is still not reachable from the outside - at least I can’t reach it. Please make sure you can reach from the outside through your browser. Once that’s working as expected, Vikunja should work.

The API Url you configured looks correct.

If you can’t get the API to be reachable from the outside, you might want to look into the reverse proxy setup.