E.filter is not a function Error and Info window is empty


is just installed the master branch of vikunja on my new debian server. I followed the following instruction pages:

https://vikunja.io/docs/install-frontend/ (using apache)

i use a mysql (mariadb) database on another server. The connection is established because all of the database structure has been created.

I also put the api url into the index.html.

Now if i want to access the vikunja page at port 80 it shows me the following:

I also cant register (it shows me nothing if i press the submit button).

Can you reach the api from the browser through the url you configured in the index.html of the frontend? You can check that by accessing the info endpoint at domain.tld/api/v1/info.


Do you have any errors in the browser console? What requests does the frontend make? (From the network tab of the inspection tools)

Now i get the error “missing or malformed jwt”:

I’ve pushed a possible fix, please update to the latest version and try again. You might need to clear your browser cache afterwards.

Updated, restarted apache2 and cleared my cache.

Still the same error in the browser console?


Okay, well that does not make sense. Have you tried with another browser? (It should work with chrome nevertheless, just trying to find out where the problem is located)

I see a request to /api/v1/tasks/all in your network pane which has a return code of 200 which should not work since you’re not logged in. Maybe that is the cause of the e.filter is not a function error message, but that should not prevent you from logging in. Could you show me the response of the request in the network tab nevertheless?

I just downloaded Firefox… same problem. The error message “e.filter is not a function” appears. I just created an account (no response if creation was successfol or not?!). After reloading the registration page, i got to the following page:

On this page i think i cant do anything.

What’s interesting about this is you’re experiencing bugs fixed since quite some time. You’re using the newest version of the frontend, so it should work.

no response if creation was successfol or not?!

You either get logged in directly or get a message if you need to confirm your email address.

There should be a token saved in localstorage now since it appears you’re logged in. Could you send me that? (Via pm if you want)

Are you able to log in through a private browsing window?

Do you have any script blockers enabled that might prevent accessing local storage?

Do you mean the browser local storage? Here:

In a private browsing windows i cant login. If i put my credentials into the fields and click on the login button, it just shows me nothing and i cant login. Even if i reload the page.

Yes, exactly. That token entry should not be undefined which seems like there’s a bug somewhere.

What requests happen if you’re logging in? What data is sent to them, what response comes back?

Can you try removing the token entry from localstorage and trying again? Though if that works, it should also work in private browsing mode.

If i delete the token and try to login, tho token will be regenerated with the same values (undefined).

What does the api return from the /api/v1/login request?

I need to see the post payload and response from the request in the networking tab.

I’ve just fixed a bug which might have caused the issue (https://kolaente.dev/vikunja/frontend/commit/5283f006f591e915dcb0262d5af91b6e6152b1dc). Could you update the frontend and try again?

How can i get the changes?