Non-Docker detailed install?

Hello, any chance for a more detailed non-dockerized install write-up? I tried about 10 times now. I can get front end and back end installed. Not sure if I’m just not connecting them properly or not. I have them installed in an Ubuntu 20.04 LXC. I can get to the back end but it does not allow login, just gives a page that says, “Current tasks- nothing to do” no buttons to click or ways to navigate.

Hey there!

A more detailed non-docker install sounds like a good idea, but first let me help you out here.

How have you configured your server (apache/nginx)? Could you show the config?

Have you set the api url in the frontend?

Can you show a screenshot of the page? I have a vague idea what it could be.

Hi, yes I have configured apache and will show the config. I have set the url in the front end as well and will share a screenshot. I thought I had all of it correct, but it just doesn’t seem to be connecting correctly. Wow, you are so responsive

<VirtualHost :80>
ServerName http://ip-to-lxc:3456 ## also tried with no port, no http, and tried with my
DocumentRoot /var/www/html/vikunja
RewriteEngine On
RewriteRule ^/?(config.json|favicon.ico|css|fonts|images|img|js) - [L]
RewriteRule ^(.
)$ /index.html [QSA,L]

also have api url set to: http://ip-to-lxc:3456/api/v1

I hate to have to ask for help but I just can’t figure it out. Also, is there anything I need to do with sqlite3? Or just have it installed and everything else is automated?

Can you reach the api from http://ip-to-lxc:3456/api/v1/info in your browser?

Do you have mod_rewrite enabled?

Does it work in private mode?

What version (frontend + api) are you using?

Could it be you have some leftover api token in your local storage of your browser? ( or open devtools > storage > local storage)

By default, the api should just work™ without any other configuration. It will use the default config.

Sorry, long week at work and did not have a chance to test.

I cannot reach the api info link

I do have mod_rewrite enabled

I am using frontend v.0.9 and api v.0.14

Oddly enough I do get a login page using private mode but nothing else works

I do not think it is anything to do with the browser as I tried a few different pc’s.

I think I am going to start from scratch and try again.

Ok, started all over and now I can get to api info and it returns the correct version info, but I still cannot past login screen.
I get nothing found when going to /api/v1
The log gives me OPTIONS 405 /api/v1/login

Have you configured CORS anywhere (Directly in vikunja or in apache)? The CORS section in the config has more details about this.

v0.9 is pretty old, you should rather use v0.14. Can you update and see if the issue persists?