Vikunja UI broke its self, not recently updated, no errors in logs


Recently my Vikunja UI (in task view) broke its self. There is no visible text box in the text input areas.
My image has not been updated since the issue first started and there are no errors in the logs for any of the containers.

I have tried this in several web browsers so not a browser issue either.

I tried to delete/recreate the containers but this had no effect. I also pulled the latest images but again, same issue.

What exactly is broken? What did you do, what did you expect to happen and what happened instead?

Which Vikunja version are you using?


Im running
Frontend Version: 0.22.0
API Version: v0.22.0

Previously, the comment/description fields had clearly visible/obvious text boxes and you could click anywhere inside them. Now, the text box is visually missing and I have to click the line that says “Enter a description…” or “Add your comment…” for it to allow text entry.

Interestingly, the demo version seems to look the same as mine - maybe this was an intentional change afterall?

Exactly, this was an intentional change. You should be able to click anywhere in the editor, not only in the placeholder field. That last part seems like a bug.

This is now fixed in c5ba7fcb73

Hi Kolaente

Thanks for the super quick bug fix.

Any way for me to revert the visual change or am I stuck with it? Personally I find it very counter intuitive. The old design matched what is typical of a UI text box basically anywhere but the new design almost looks like the page hasn’t loaded correctly!


Currently, there’s no way to change that via a setting. We might change the layout of it in the future but there’s nothing planned directly right now.

Ok no problem - at least I know its not broken (which is the main thing)

Thanks again