Vikunja says I am offline


I have set up Vikunja a few weeks ago and it has worked great so far. Now when I open the URL in Chrome, I get a pretty error message by Vikunja that I am offline. Interestingly enough, this only happens in Chrome (even in Incognito without any extensions) not in Firefox. I run Vikunja in Docker with Traefik 3 behind it. The developer console in Chrome does not show any errors.

Any idea what could cause this or how I can get to the bottom of it? Increasing the log level by setting VIKUNJA_LOG_LEVEL: DEBUG did not have any effect on the verbosity of the logs. I can see the request in the logs though:

frontend | - - [04/Aug/2023:18:10:46 +0000] "GET /login HTTP/1.1" 200 1627 "-" "Mozilla/" "MYIP"

I’m not sure that I have a solution but I’ve been experiencing something similar. I’ve been poking it a lot to ensure that I can easily reinstall and restore without issues if/when something breaks.

That’s my post. What does your error say, specifically? The one you get in the browser. Can you post a screenshot? I get something like this, and I wondered if yours was similar:

Does yours complain about the API URL being correct, or something else?

In either case I find that if I remove the locally stored data from that site (in Brave, but essentially it’s Chrome), then restart the browser, I can get back in. What causes just Brave/Chrome to do this is still a mystery.

Thanks for your reply! The error page actually looks different, it is a full-page “You are offline” message in pink. Deleting locally stored data in Chrome did not fix the issue. I actually got rid of the Vikunja data directory, restarted the Docker container and did not encounter the issue since. Not sure what caused it.

The offline message depends on whether you have internet or not. That’s the first thing I’d check.