Synology: vikunja working locally but not via proxy

Hello,

I managed to install vikunja via docker-compose on my synology nas (i used portainer’s stacks and it was surprisingly easy for a newbie like me to follow your “Example without any proxy”) :slight_smile:
locally, everything works fine :+1:

Now i would like to access vikunja from outside: synology has a pre-installed proxy so i connected my local vikunja 192.168.1.10:8088 to my domain vikunja_mydomain_com (like i already did with other containers) but it does not work: there is a “network error” message on the login page :confused:

Any idea how i can correct this “network error” (+ remove the register button) ?

i tried adding these env. variables but it doesn’t work :
VIKUNJA_SERVICE_FRONTENDURL: https://vikunja.mydomain.com
VIKUNJA_SERVICE_ENABLEREGISTRATION: 0

What part of Vikunja did you connect to your proxy? Frontend or API?

Because your browser actually makes the requests to the api directly, it needs to have access to it. That means you have to expose both containers, on different ports.

Once you’ve done that you need to configure the API Url in your frontend, check out this part of the docs for that.

Thanks for your swift reply but i’m not sure i understood correctly :

  • i created a proxy to redirect the api “192.168.1.10:3344” to a domain “api_mydomain_com”
  • so now both containers are exposed
  • i also modified the frontend container and changed VIKUNJA_API_URL to “https_api_mydomain_com/api/v1”
    but i still get a network error when i try to login via the frontend “vikunja_mydomain_com”

Can you access the api from your browser at https_api_mydomain_com/api/v1/info?

yes : i get a json page that starts with version “v0.18.1”

edit:
it works ! :smile: i had to change the url on the login page too (on top of the login field)

Thank you - if you want i can send you the exact steps to make it work on a synology nas so you can maybe add it to your docs ?

1 Like

Glad you figured it out!

If you could provide the steps for the docs that would be awesome, if you feel up to it you could also send a PR directly.