Trello Migration not working on fresh install ("Migration already running")


I just today installed Vikunja and wanted to migrate my board(s) from Trello. I edited the configuration and I am getting redirected to the Trello auth page as I should.

But after I get redirected back to the Vikunja “check back later” message, nothing ever gets imported.
No errors get logged into either console, even with debug logging enabled.

While troubleshooting, I took a look into the Browser Dev Tools, and the request to /api/v1/migration/trello/migrate responds with “{message: “Migration already running”, running_since: “0001-01-01 00:00:00 +0000 UTC”}”. Again, this is on a freshly installed instance. I also tried to wipe the database and try again, with the same result.

I am using the official Docker images (api and frontend) on an unRAID server.
Everything else is working fine.

You should see a debug message in the logs (after enabling debug logging), saying [Trello Migration] Starting migration for user <your user id>. Do you see that?

Which version are you using?

I just wiped the database and tried again. There is no such message in the logs. The closest thing is ▶ migration/Migrate 0c0 Ran all migrations successfully., but that probably is about the database migrations after wiping and restarting. I am using v0.22.1.

I am using OpenID for Authentication, could that maybe have something to do with it?

This is now fixed in 205f330f8a - please check with the next unstable build (once the ci is done).

Thank you very much! It works now.