Reminder Duplication

Editing a task which already has a reminder, duplicates the reminder.

Example:
If I add a reminder to a task (as pictured):

Then add a second reminder, leave the task and reopen the task - you can see that the first reminder is duplicated:

This also happens when a reminder is set, then something else that is not a reminder is changed. For example if changing the due date, the reminder dates are duplicated. (Need to leave the task, then re-open the task to see this happen).

I wasn’t able to reproduce this on try.

Does the duplicated reminder persist across browsers and reloads?

Can you reproduce this with a new task, if so what exact steps did you do?

What browser/os and vikunja version are you using?

Hi Konrad,

Yes, the issue does persist across browsers and reloads

  • Create task
  • Edit task
  • Set reminder
  • Set a second reminder
  • Exit task (back to main list)
  • Reopen Edit task
  • extra reminder has appeared
    note: adding a third reminder will once again duplicate all the initial reminders - so the number of reminders grows exponentially for each new reminder! (1, 3, 7, 15)

I am using Google Chrome on Windows to access a vikunja instance hosted on FreeBSD (via an NGINX reverse proxy). I compiled the vikunja API from source last week. Frontend is the master release dated ‘09/06/2020’ from https://dl.vikunja.io/frontend/

Worked on my windows 10 vm with the latest chrome installed:

Are you able to reproduce this on try?

Unable to reproduce using try.
Perhaps there is a version mismatch between when I pulled the master repo and what is presently hosted on try? I pulled the master repo last week. When was try updated last? (it may be a regression bug?)

Try is automatically updated with each push to master therefore it is always up to date. You can check the version by pulling up he browser console, there should be a log (info) message with the current version of the frontend.

So your version is probably older :slightly_smiling_face:

Ah that would make sense.

My version: 0.14.0+86-2e614463c2
Try version: 0.14.0+106-9ef1b67e72

I pulled mine from the most recent release from the vikunja.io site which is dated back in July. Perhaps it’s worth updating the frontend release?

The frontend releases on https://dl.vikunja.io are updated the same way as try - automatically with every push to the master branch (or releases, but that’s not applying here) :slight_smile:

You can see this in the date for master it was updated yesterday:

I can see from your version string you’re running the master version and not a release.

You can also see from the +106 part of the try version it is more up to date than your version. In fact, that’s why I’m stressing so much to verify every bug on try since that’s always up to date.

Could you update your version to see if the issue still persists?

Issue still persists when updated to 0.14.0+86-2e614463c2 :frowning:

Perhaps it’s an API problem?

EDIT: that should say 0.14.0+106-9ef1b67e72 :sweat_smile:

What api version are you running? (vikunja version)

Sorry for the delayed response - life gets busy sometimes!

I’ve just done a complete update of both the backend and frontend from the master branches.

The issue still persists for my isntallation :frowning: but again, no issue when using try. I’m all out of ideas :joy:

I’m afraid I can’t help you if I can’t reproduce it - even more so if it seems to work on try.

One more thing though: we now have a desktop version of the frontend. Do you get the same error if you use that with your api installation?