No fullscreen in android browser

Hello everyone, I have just set up vikunja on my home server. Everything is running very well! Unfortunately, I have the problem that vikunja cannot be opened fullscreen on my android smartphone. When I create a shortcut on the home screen from the browser (Brave and Chrome tested), it always opens with the navigation bar. With all my other services it works in fullscreen. Can anyone please help me?

Are you running the latest version? Are you accessing Vikunja or the other services via https?

thx for your reply. yes, im runnig the latest docker hub release. in vikunja i use ssl only for external connections. in the most other services i use ssl for local and external connections without problems.

if i use the home screen shortcut, vikunja will always open as a normal brower tab, not as a “standalone” web application. I use other self hosted services like kitchenowl which are working fine.

PS: Im also interessted in a way to use my self signed certificates to locally access vikunja over https.

Ive also checked this issue on ios with safari and got the same result. On Windows it is working fine.

It works fine for me. IIRC you must access Vikunja via https or otherwise it won’t install as a pwa. (That’s a requirement from the browser manufacturers)

Hmmm. Strange. Im using the same SSL configuration for Vikunja as for other services which are working fine. The only special thing with Vikunja is that im using the nginx config from the Docs. Maybe this is a problem?

And is there any way to fix it? And how could it work on Windows with the same config?

I’m not sure, it does not look like a Vikunja issue. It might be os/browser dependent.

And you’re accessing Vikunja via https on your phone as well? And it does not let you open it in full screen from the home screen?

Yes, its 100% the same URL and network connection.

Ive tried it on ios, Android and GrapheneOS with Chrome, Brave, Vanadium and Safari. And unfortunally its not working. Only on Windows everything is fine.

Ive figured out where the problem is. I use Cloudflare Tunnel to reach Vikunja. If i disable the Cloudflare Access Policy for Vikunja it is woking fine, as a PWA.

Ive also created a topic on Cloudflare Community

Thanks a lot for your help! Vikunja is a great service!