My vikunja instance creates tasks with due date time of 9AM for tasks with the word 'today' word in it

Is it normal? I’d think it would create due date to 11:59PM. I tried todoist as quick magic add. Same thing. Also, when I check tasks that are due today, it doesn’t show me tasks that are due at the time of 11:59PM.

It “rounds” to the next 3 hour interval (9:00, 12:00, 15:00, 18:00, 21:00) if you don’t specify a time.

Ah I see. Also, why do tasks with due date time of say 23:59 don’t show up on Upcoming Today range? Does it also follow the 3 hour interval rule?


That would be a bug imho, but I cannot reproduce this behaviour locally. It shows up perfectly fine when selecting “today”.

How does it look on the public instance?

Just tried it on demo instance. It’s not showing on there also. Have a look below:

That looks like a timezone issue to me then - for me, the very same task shows as “due in 10h” (same for you), however 10h from now is 5:59am CET for me. I’m not deep enough in the code yet to understand what’s happening, but that looks like an issue to me.

My assumption right now would be that the time range is calculated on server side (can be seen when inspecting the API call, the time expressions are passed as filter to the backend)

And as the demo instance is hosted in Germany (CET timezone), it’s showing the same behaviour on my client (same timezone). The client timezone is not taken into account, it’s always the timezone configured on the server side.

If you’re hosting Vikunja yourself, you should be able to test and verify this by setting the timezone in config. Might to be worth reporting it in the issue tracker.

I’m in EST timezone. So 10 hrs from now is midnight for me. But I will wait for a day and see if I get a confirmation of bug from kolaente before reporting the bug. Thanks for your response :slight_smile:

That’s exactly what is happening. The demo is running on a server using utc+0 as timezone.

To fix this, we’d need to add another parameter “timezone” or something like that which we then pass to the query. Or we just always take the time zone from the user? (Ultimately that’s a design question, you won’t need to set your time zone manually when browsing the frontend)

The filter now takes your currently configured time zone into account (a66e26678e). Please check if it works as you intended in the next unstable build!

(Note that the timezone you have set in the settings is not necessarily the same as the one you’re seeing dates in the frontend as. That’s due for improvment as well)

1 Like

Just tried the latest unstable release but got this error when I went to Upcoming page:

Now fixed in 85fb8e3443 - please check with the next unstable build (also on try), in ~45min.


Awesome! Tried it both on unstable release and on try and today shows today’s task now. Thanks!!