I think my setup is broken (email, alphabetical sorting, data export)

Hello. Been enjoying Vikunja a lot, and while I can still use it, I face several problems:

  • I don’t get notifications anymore
  • Alphabetical sorting never worked for me since it was implemented
  • I can’t export my data

My major problem is that I can’t export my vikunja data as a backup. I don’t get the email, and I don’t find the backup in ~/files/user-export-tmp/

I’m willing to perform a fresh install, but I will loose all my data.
Is there any other way I can safely backup and restore my data on a fresh install ?

This is an SOS :sweat_smile:

My docker-compose:

version: '3.3'

    image: mariadb:10
    command: --character-set-server=utf8mb4 --collation-server=utf8mb4_unicode_ci
      MYSQL_USER: ------
      MYSQL_PASSWORD: xxxxxx
      MYSQL_DATABASE: vikunja
      - /srv/Files/Vikunja/db/:/var/lib/mysql
    restart: unless-stopped
    image: vikunja/api
      VIKUNJA_MAILER_HOST: ssl0.ovh.net
      VIKUNJA_MAILER_USERNAME: user@domain.com
      VIKUNJA_MAILER_FROMEMAIL: user@domain.com
      - 3456:3456
      - /srv/Files/Vikunja/files/:/app/vikunja/files
      - db
    restart: unless-stopped
    image: vikunja/frontend
      - 9990:80
    restart: unless-stopped

Frontend Version: 0.19.1
API Version: v0.19.2

Can you check with the vikunja testmail command if your email setup is working correctly?

What are you trying to sort?

What exactly does not work? Please provide steps to reproduce.

If you want to backup and restore the whole instance check the vikunja dump and restore commands.

Thank you for your answer.
Before I can answer precisely, you’ll have to forgive that awkward question : where do I input the cli commands ? I get a command not found on my host.

You’ll need to run it in the api docker container.

There are two ways to do this:

  1. Run docker-compose exec api /app/vikunja/vikunja <subcommand> (where <subcommand> is dump etc)
  2. Get a shell into the api container with docker-compose exec api sh and then run ./vikunja <subcommand>.
1 Like

Thanks a lot :slight_smile:

Looks like testmail can’t be sent

2022/10/27 21:01:26 No config file found, using default or config from environment variables.
2022-10-27T21:01:26.679964402Z: INFO    ▶ cmd/func10 001 Sending testmail...
2022-10-27T21:02:22.222834638Z: ERROR   ▶ cmd/func10 002 Error sending test mail: dial failed: EOF

I got a simple grocery list that I’d like to sort alphabetically. The filter just has no effect.

Go to settings > export your Vikunja data > input password > request a copy of my Vikunja data.
I get a “success” message but no data.

Here’s the logs after a dump

2022/10/27 21:00:09 No config file found, using default or config from environment variables.
2022-10-27T21:00:09.856631803Z: INFO    ▶ migration/Migrate 04d Ran all migrations successfully.
2022-10-27T21:00:09.858638534Z: INFO    ▶ [EVENTS] 053 Adding handler, handler_name=poison.logger, topic=poison
2022-10-27T21:00:09.858786444Z: INFO    ▶ [EVENTS] 055 Adding handler, handler_name=namespace.deleted.namespace.counter.decrease, topic=namespace.deleted
2022-10-27T21:00:09.858846331Z: INFO    ▶ [EVENTS] 056 Adding handler, handler_name=task.comment.created.task.comment.notification.send, topic=task.comment.created
2022-10-27T21:00:09.858942648Z: INFO    ▶ [EVENTS] 057 Adding handler, handler_name=task.assignee.created.task.assigned.notification.send, topic=task.assignee.created
2022-10-27T21:00:09.859074823Z: INFO    ▶ [EVENTS] 058 Adding handler, handler_name=task.assignee.created.task.assignee.subscribe, topic=task.assignee.created
2022-10-27T21:00:09.859538019Z: INFO    ▶ [EVENTS] 059 Adding handler, handler_name=team.member.added.team.member.added.notification, topic=team.member.added
2022-10-27T21:00:09.859603229Z: INFO    ▶ [EVENTS] 05a Adding handler, handler_name=task.comment.edited.handle.task.comment.edit.mentions, topic=task.comment.edited
2022-10-27T21:00:09.859731584Z: INFO    ▶ [EVENTS] 05b Adding handler, handler_name=user.created.increase.user.counter, topic=user.created
2022-10-27T21:00:09.859879181Z: INFO    ▶ [EVENTS] 05c Adding handler, handler_name=list.created.list.counter.increase, topic=list.created
2022-10-27T21:00:09.860082979Z: INFO    ▶ [EVENTS] 05d Adding handler, handler_name=list.created.send.list.created.notification, topic=list.created
2022-10-27T21:00:09.860141947Z: INFO    ▶ [EVENTS] 05e Adding handler, handler_name=task.created.task.counter.increase, topic=task.created
2022-10-27T21:00:09.860342471Z: INFO    ▶ [EVENTS] 05f Adding handler, handler_name=task.created.task.created.mentions, topic=task.created
2022-10-27T21:00:09.860396787Z: INFO    ▶ [EVENTS] 060 Adding handler, handler_name=task.deleted.task.counter.decrease, topic=task.deleted
2022-10-27T21:00:09.860447914Z: INFO    ▶ [EVENTS] 061 Adding handler, handler_name=task.deleted.task.deleted.notification.send, topic=task.deleted
2022-10-27T21:00:09.860789574Z: INFO    ▶ [EVENTS] 062 Adding handler, handler_name=user.export.requested.handle.user.data.export, topic=user.export.requested
2022-10-27T21:00:09.860847715Z: INFO    ▶ [EVENTS] 063 Adding handler, handler_name=list.deleted.list.counter.decrease, topic=list.deleted
2022-10-27T21:00:09.86095318Z: INFO     ▶ [EVENTS] 064 Adding handler, handler_name=team.deleted.team.counter.decrease, topic=team.deleted
2022-10-27T21:00:09.861090048Z: INFO    ▶ [EVENTS] 065 Adding handler, handler_name=task.updated.task.updated.mentions, topic=task.updated
2022-10-27T21:00:09.86135708Z: INFO     ▶ [EVENTS] 066 Adding handler, handler_name=namespace.created.namespace.counter.increase, topic=namespace.created
2022-10-27T21:00:09.861415791Z: INFO    ▶ [EVENTS] 067 Adding handler, handler_name=team.created.team.counter.increase, topic=team.created
2022-10-27T21:00:09.865172763Z: INFO    ▶ [EVENTS] 07e Starting handler, subscriber_name=task.assignee.created.task.assigned.notification.send, topic=task.assignee.created
2022-10-27T21:00:09.865314301Z: INFO    ▶ [EVENTS] 080 Starting handler, subscriber_name=task.assignee.created.task.assignee.subscribe, topic=task.assignee.created
2022-10-27T21:00:09.865540469Z: INFO    ▶ [EVENTS] 085 Starting handler, subscriber_name=list.deleted.list.counter.decrease, topic=list.deleted
2022-10-27T21:00:09.865481517Z: INFO    ▶ [EVENTS] 083 Starting handler, subscriber_name=task.comment.edited.handle.task.comment.edit.mentions, topic=task.comment.edited
2022-10-27T21:00:09.865372602Z: INFO    ▶ [EVENTS] 081 Starting handler, subscriber_name=list.created.list.counter.increase, topic=list.created
2022-10-27T21:00:09.865632231Z: INFO    ▶ [EVENTS] 087 Starting handler, subscriber_name=namespace.created.namespace.counter.increase, topic=namespace.created
2022-10-27T21:00:09.865430399Z: INFO    ▶ [EVENTS] 082 Starting handler, subscriber_name=task.created.task.created.mentions, topic=task.created
2022-10-27T21:00:09.865486653Z: INFO    ▶ [EVENTS] 084 Starting handler, subscriber_name=task.deleted.task.counter.decrease, topic=task.deleted
2022-10-27T21:00:09.865576608Z: INFO    ▶ [EVENTS] 086 Starting handler, subscriber_name=team.member.added.team.member.added.notification, topic=team.member.added
2022-10-27T21:00:09.865697042Z: INFO    ▶ [EVENTS] 088 Starting handler, subscriber_name=task.deleted.task.deleted.notification.send, topic=task.deleted
2022-10-27T21:00:09.865754728Z: INFO    ▶ [EVENTS] 08a Starting handler, subscriber_name=task.created.task.counter.increase, topic=task.created
2022-10-27T21:00:09.865805958Z: INFO    ▶ [EVENTS] 08b Starting handler, subscriber_name=team.created.team.counter.increase, topic=team.created
2022-10-27T21:00:09.865856428Z: INFO    ▶ [EVENTS] 08c Starting handler, topic=list.created, subscriber_name=list.created.send.list.created.notification
2022-10-27T21:00:09.8657177Z: INFO      ▶ [EVENTS] 089 Starting handler, subscriber_name=user.created.increase.user.counter, topic=user.created
2022-10-27T21:00:09.865176265Z: INFO    ▶ [EVENTS] 07f Starting handler, topic=poison, subscriber_name=poison.logger
2022-10-27T21:00:09.865922161Z: INFO    ▶ [EVENTS] 08d Starting handler, subscriber_name=namespace.deleted.namespace.counter.decrease, topic=namespace.deleted
2022-10-27T21:00:09.865970904Z: INFO    ▶ [EVENTS] 08f Starting handler, subscriber_name=task.updated.task.updated.mentions, topic=task.updated
2022-10-27T21:00:09.865967827Z: INFO    ▶ [EVENTS] 08e Starting handler, topic=team.deleted, subscriber_name=team.deleted.team.counter.decrease
2022-10-27T21:00:09.866024748Z: INFO    ▶ [EVENTS] 090 Starting handler, subscriber_name=user.export.requested.handle.user.data.export, topic=user.export.requested
2022-10-27T21:00:09.866036224Z: INFO    ▶ [EVENTS] 091 Starting handler, subscriber_name=task.comment.created.task.comment.notification.send, topic=task.comment.created
2022-10-27T21:00:09.858570103Z: INFO    ▶ dump/Dump 052 Start dumping config file...
2022-10-27T21:00:09.891844679Z: WARNING ▶ dump/Dump 092 No config file found, not including one in the dump. This usually happens when environment variables are used for configuration.
2022-10-27T21:00:09.893095011Z: INFO    ▶ dump/Dump 093 Dumped config file
2022-10-27T21:00:09.898643791Z: INFO    ▶ dump/Dump 094 Dumped .env file
2022-10-27T21:00:09.898822488Z: INFO    ▶ dump/Dump 095 Start dumping version file...
2022-10-27T21:00:09.900354778Z: INFO    ▶ dump/Dump 096 Dumped version
2022-10-27T21:00:09.900465495Z: INFO    ▶ dump/Dump 097 Start dumping database...
2022-10-27T21:00:10.072638674Z: INFO    ▶ dump/Dump 0f0 Dumped database
2022-10-27T21:00:10.07278484Z: INFO     ▶ dump/Dump 0f1 Start dumping files...
2022-10-27T21:00:10.075124951Z: CRITICAL        ▶ cmd/func2 0f7 error saving file: open files/1: no such file or directory

I don’t know how to interpret that.

Can you reproduce this on try?

That’s likely related to mails not working. Was there anything about this in the logs?

Did you delete the files? The error message indicates there’s a file metadata entry in the db but the file on disk was deleted. A quick fix would be to remove the file with the id 1 from the files table.

I tried. It won’t sort either. I also tried on a test setup of mine. It won’t work either. I tried on different browsers and machines too.

I fixed it using port 587 instead of 465

I don’t remember deleting a file, but I don’t really trust myself either :sweat_smile:
Sorry again for the awkward question, but how would I do that ?

WHERE id = 1;

Maybe this ? Just a wild guess as I don’t know what I’m doing…

Hello @kolaente . Hope you had a great weekend.
I’m sorry to be that insistent, but my wife is threatening to get a divorce if I don’t give her that alphabetical sorting :sweat_smile:

I hope my answers in my previous post are of any help.

Where exactly are you trying to sort tasks? In the table view?

That should work, yes.

List or table view. Sorting just doesn’t work. On my instance, on my fresh and brand new test instance, and on try.

Would it help if I PMd you temporary creditentials to my instance ?

If it does not work on try it looks like it’s a general issue. I’ll take a look.

Alphabetical Sorting should be fixed in 612e592da7. Please check with the next unstable build (~30 minutes on try) if the problem really went away.

Yes ! It’s working on try :partying_face:

Maybe my wife will stop threatening me with that divorce then :stuck_out_tongue:

Any idea when it will be available on stable ?

It will be available on stable once the next release is out. Shouldn’t be more than two weeks as of right now.

It’s working great now. Thanks you @kolaente :slight_smile: