Error refreshing user info, fresh install

I’m trying to install vikunja on, the backend seems ok (I was able to create an user), but every time I try to log in, I have the Error: Error while refreshing user info: error.

I saw this post, tried to complete every config options of the config file, but still cannot access vikunja.

Can you check if the user you’re logging in with has a language set in the db? Just to make sure it’s not the problem mentioned in the thread you linked.

Hello, thank you for your answer.
I recreated an user and checked the db :
1 | | kevin | *** | kevin@*** | 0 | initials | 0 | local | | f | f | f | t | 9:00 | 1 | 0 | fr | Europe/Paris | | | null | 0 | 2023-08-22 18:16:00 | 2023-08-22 18:16:00

Is there anything in the server logs of the api when you get that error message? If you check with your browser’s Dev tools, what’s the response you get back from the api leading to the error message?

I have this warning message with dev tools :
Source map error: Error: JSON.parse: unexpected character at line 1 column 1 of the JSON data Resource URL: Source Map URL:

This looks like a bug in the frontend. Can you enable sentry and check again? That would allow me to see the error causing this.

Not sure of what I should do. I created an account at sentry, created a project (which plateform should I use, vuejs ?) and put the client key in the vikunja config ?

No need for all that, you only need to switch this to true in the index.html: frontend/index.html at main - frontend - Gitea

If you’re using docker, add the VIKUNJA_SENTRY_ENABLED env variable with a value of true to the frontend container.

Ok, I went too far :grinning: ! Shoud be good.

Took another look at it, not sure where that error is coming from. Nothing in sentry, that may be caused by the exception being catched or similar. Can you switch to unstable and check again? There are more debugging infos added since the last release.

I’ve updated the frontend and the backend.

Did you configure a default language? It looks like the language of your user is fr but that does not exist - it should be fr-FR instead.

Bingo, that was the problem ! Changing the config and resetting the db did the trick ! Thank you very much ! I think I tried earlier with fr-fr, not fr-FR …

Glad it works now! I’ve just pushed a change to prevent this from happening again in the future.

Cool, I hope I will be the last to make that mistake !