Deleting Views breaks Project

I only need kanban-view, so I tried deleting the other views. That leads to a broken project, that doesn’t display any tasks at all. I don’t see any logmessages indicating an error though (loglevel vor all logs is DEBUG)

Tasks are still usable via overview and when I duplicate the project, all tasks are copied to the second project.

Version: v0.23.0+413-ecd002dca3

Update: Just checked on mobile (Android, Chrome) and there’s a difference: All deleted views are still there and usable. Rechecked on Desktop (Windows, Chrome + Firefox) and there the problem persists

I’ve seen a similar behaviour, have not tracked it down yet. Basically I believe that when deleting the view you’ve currently selected, it’s still selected as default view for the project.

This can be avoided by switching to a view you want to keep (e.g. if you want to keep Kanban, switch to Kanban and delete the others). This should keep the project intact. After the fact, you can “fix” it by removing the projectView entry from browsers local storage, see attached Video.

I’ve created an issue for this in the issue tracker.

1 Like

This seems to do the trick, thanks!

I’m not entirely sure, though. One project was fixable by clearing the local storage as described, but the project I duplicated was not. I also tried clearing all storage for my vikunja installation, but to no avail. I ended up deleting and reimporting (which is good enough for me atm)

Good to hear it’s working! I’ve proposed a change that should fix the issue, lets see if I missed anything crucial :slight_smile:

Regarding the duplicated project, do you see anything in the browser console and/or Vikunja logs?

I tried to reproduce the error, but was unable to. I produced an error, though. Not sure if it’s helpful, but here’s a step by step:

* deleted all in Vikunja
* fresh import from Trello
* delete views, while they are open (to reproduce the original error)
* duplicate the project
    red toast message with internal error
    standard.log: 2024-03-26T15:10:07.789954144+01:00: ERROR      ? handler/CreateWeb 212d7 file was not downloaded from unsplash [FileID: 185]
    browser console:
        PUT 500 (Internal Server Error)
            (Internal Server Error)
            (anonymous) @ xhr.js:258
            xhr @ xhr.js:49
            dispatchRequest @ dispatchRequest.js:49
            Promise.then (async)
            _request @ Axios.js:146
            request @ Axios.js:40
            (anonymous) @ Axios.js:209
            (anonymous) @ bind.js:5
            create @ abstractService.ts:376
            Se @ projects.ts:296
            p @ duplicate.vue:45
            callWithErrorHandling @ runtime-core.esm-bundler.js:195
            callWithAsyncErrorHandling @ runtime-core.esm-bundler.js:202
            emit$1 @ runtime-core.esm-bundler.js:715
            $ @ create-edit.vue:94
            (anonymous) @ create-edit.vue:95
            se.<computed>.se.<computed> @ runtime-dom.esm-bundler.js:1452
            callWithErrorHandling @ runtime-core.esm-bundler.js:195
            callWithAsyncErrorHandling @ runtime-core.esm-bundler.js:202
            emit$1 @ runtime-core.esm-bundler.js:715
  <computed>.we.<computed> @ BaseButton.vue:95
            callWithErrorHandling @ runtime-core.esm-bundler.js:195
            callWithAsyncErrorHandling @ runtime-core.esm-bundler.js:202
            se @ runtime-dom.esm-bundler.js:693
* delete local storage projectView
* <CTRL><F5>
* views work as expected

This is just the frontend part of the error, we’d need to see the Backend logs from Vikunja as well to understand what has caused the 500 error. It certainly should not happen though, so any additional information you have would be helpful.

That said, the proposed fix is not in unstable yet

happy to provide additional logs. I have activated file logging at level DEBUG for all. Which do you need?

root@oghma:/opt/vikunja/logs# ls
database.log  events.log  http.log  mail.log  standard.log

standard.log should have the info we’re looking for.

The original issue should now be fixed in the latest unstable build, deleting views should no longer cause these issues. Give it a shot :slight_smile:

1 Like

Sorry, for the delayed reply, it works just perfect! Thanks for fixing :slight_smile:

1 Like