Vikunja self-host (Cloudron) not working

When i try to login, i either get 405 error, or 502.

More details are in this thread:

Try disabling the redis cache.

That doesn’t seem possible within the Cloudron setup.

Although, i’ve tried to restart the Redis container multiple times, but it gives the same result.

Yeah that’s a problem with Vikunja’s usage of redis. The redis implementation for database caching has bugs and no performance improvements over not using it, sometimes it’s even worse than that. The only reason to use redis anway is running a multi-node HA setup which Cloudron is not even meant for. We will remove it completely in a future release and maybe re-implement something like this at some point.
Using redis for keyvalue storage should work, bug again, has no benefit over just using memory if you don’t run Vikunja in a HA setup.

I don’t know anything about Cloudron, so you’ll need to talk to them to get this disabled I’m afraid. Don’t they allow adding additional config to Vikunja?

1 Like

They allow config modification, but only to a certain extent.
In this case, seems like the cache/redis config has been hardcoded.