Synology Installation: API not reachable (?)


I’m attempting to get Vikunja set up on my Synology NAS. I am just looking to get it up and running locally within my private network, so I skipped any proxy-setup. All I want is to access it via the IP and specified port.

I tried to set it up with the recommended configuration
This creates containers that run fine and I can access the Frontend via my.ip.address:4321/register
However, the registration can never be completed: All I get when clicking the “Register” button after filling out the form is a quick “loading” plate but nothing happens after that. I assume this might be because I can’t seem to reach my.ip.address:3456/api/v1. But how do I fix that? I’m on a private network but don’t have the privileges to configure external access e.g. via ddns or reverse proxy if that were the root cause

Thank’s a lot!

Are you able to reach my.ip.address:3456/api/v1/info in your browser?

The frontend calls that api directly from your browser to make api calls so the api has to be reachable for it, at least from your internal network.

I’m not, it’s not reachable. I’ve seen that to be suggested as the root of the issue in a handfull of threads on your forum…
The problem is: how do I solve it? :innocent:

Thank’s a lot for the reply!

– addendum –
My current docker-compose.yml looks like this:

version: '3'

    image: mariadb:10
    command: --character-set-server=utf8mb4 --collation-server=utf8mb4_unicode_ci
      MYSQL_ROOT_PASSWORD: supersecret
      MYSQL_USER: vikunja
      MYSQL_PASSWORD: secret
      MYSQL_DATABASE: vikunja
      - ./db:/var/lib/mysql
    restart: unless-stopped
    image: vikunja/api
      VIKUNJA_SERVICE_JWTSECRET: <a super secure random secret>
      - 3456:3456
      - ./files:/app/vikunja/files
      - db
    restart: unless-stopped
    image: vikunja/frontend
      - 4321:80
    restart: unless-stopped

I had also tried to assign “network-mode: bridge” to all services in hopes it would be a simple problem with the separate vikunja-network that messed with my browser/NAS, but I had no more luck than with the above setup.

Did you add the proxy rules mentioned in the docs? As far as I understand it the nas won’t expose anything to the network by default (I don’t know anything about Synology NAS’s though)

I’ve had mine for years, can’t even remember how it ships. But I did not add the reverse-proxy rules stated in the docs. I can’t configure external (meaning outside of my network) access to the nas at the moment as I do not have access to configure the router managing in- and outgoing traffic (just another small router that I use to create my own local network within the third party network which mirrors the wifi available). Or is there a point in doing reverse proxies within (!) a local network…?

I literally didn’t change anything after my last post. I just waited. In the morning, it still wasn’t working but now 8 hours later, it’s all sunshine and rainbows… maybe the backend just took literally hours to be up and running (although the protocols said it was done much earlier).

Anyway: I’m excited to try out the self-hosted version and see how great it is! Please keep up the great work :slight_smile:

1 Like