Local User Password with OIDC Backend - getting 500 Error


I am using Vikunja with Authentik as OIDC backend.
I ran into a bug when trying to use the calendar sync.
This requires access via username and password.
I assumed to be able to set an “app”-password for Vikunja as it is used in similar use cases (Auth via OIDC).
However, the settings require an old password, which not exists. I get a 500 error, the vikunja-api logs indicate that no local password is stored 2022-06-27T08:37:43.077740133Z: ERROR ▶ v1/UserChangePassword 1ef crypto/bcrypt: hashedSecret too short to be a bcrypted password

I wanted to create a git issue, but the repo gives me a 500: https://kolaente.dev/vikunja/api/issues

I set up vikunja via docker, with image: vikunja/api and vikunja/frontend

Thanks for this cool software!

At least with the latest unstable release you should be able to create an app password exactly for that usecase. Can you try with that version to see if your problem is already solved there?

The Gitea instance should work again.

Thanks for your reply, thats great to hear.
Is the latest unstable release available as docker image,
such that I can simply replace image: vikunja/api ?

Yes, unstable releases are available as the unstable docker image tag. You should be able to simply change the image to vikunja/api:unstable. I’d recommend changing the frontend container to unstable as well since they are more compatible than the stable and unstable versions.

Hey, the unstable version looks great.
I was able to create an app token.
However, I can’t login with it
The log for the api says
´´2022-06-30T20:19:52.909044712Z: ERROR :arrow_forward: caldav/BasicAuth 536 Error during basic auth for caldav: crypto/bcrypt: hashedSecret too short to be a bcrypted password``
I am using a mysql backend,

attached is an screenshot of the user_tokens table which looks like a bcrypt hash

Looks like there has been a problem when using the caldav tokens in combination with an openid account. I’ve pushed a fix for this in 4429ba2da1, please check with the next unstable version in ~45 min once the ci released it.

I tested it once you wrote back, and just now.
It still does not work, and the api shows the same error,
2022-07-11T17:25:06.559661843Z: ERROR ▶ caldav/BasicAuth 0ed Error during basic auth for caldav: crypto/bcrypt: hashedSecret too short to be a bcrypted password
In about it says:
Frontend-Version: 0.18.1+1882-db805ade48 API-Version: v0.18.1+248-12557163b2
Am I testing the correct version?

Looks like the version you’re using does not have the fix. Can you upgrade to the last unstable build and try again?

Is it in the current vikunja/api:unstable docker images?
If yes, I will need to get Portainer to pull the latest

Yes, the unstable docker image has it.