[Help Request] Unable to send e-mails via Proton Mail SMTP

Hi people!

Firstly, thank you in advance for your time and help :slight_smile:

Long story short, I am running Vikuninja in a Docker Swarm inside a VPS on Linode, and I am not being able to send e-mails via Proton Mail SMTP. The error that I am getting is the following:

ERROR ▶ mail/func1 0fd Error during connect to smtp server: dial tcp 185.70.42.135:587: i/o timeout

The issue is the fact that, not only, the SMTP configuration is correct, but the server is reachable from within the container:

/app/vikunja # ping smtp.protonmail.ch
PING smtp.protonmail.ch (185.70.42.135): 56 data bytes
64 bytes from 185.70.42.135: seq=0 ttl=42 time=8.446 ms
64 bytes from 185.70.42.135: seq=1 ttl=42 time=8.366 ms
64 bytes from 185.70.42.135: seq=2 ttl=42 time=8.157 ms
64 bytes from 185.70.42.135: seq=3 ttl=42 time=8.448 ms
64 bytes from 185.70.42.135: seq=4 ttl=42 time=8.509 ms
64 bytes from 185.70.42.135: seq=5 ttl=42 time=8.777 ms
64 bytes from 185.70.42.135: seq=6 ttl=42 time=8.572 ms
64 bytes from 185.70.42.135: seq=7 ttl=42 time=8.532 ms
^C
--- smtp.protonmail.ch ping statistics ---
8 packets transmitted, 8 packets received, 0% packet loss
round-trip min/avg/max = 8.157/8.475/8.777 ms

Here are my configurations:

VIKUNJA_MAILER_ENABLED: true
VIKUNJA_MAILER_HOST: smtp.protonmail.ch
VIKUNJA_MAILER_PORT: 587
VIKUNJA_MAILER_AUTHTYPE: plain
VIKUNJA_MAILER_USERNAME: noreply@mydomain.com
VIKUNJA_MAILER_PASSWORD: /run/secrets/smtp_password
VIKUNJA_MAILER_FROMEMAIL: noreply@mydomain.com

The documentation points that STARTTLS is used by default, which is the correct configuration according to Proton Mail documentation. It is important to note that the SMTP server is working as expected, since I could send e-mails via other tools.

I also tested with the password available as environment variable and the same error occur. Probably I am doing something wrong but to be honest is not clear what.

Lastly, debug log level does not provide any useful information regarding this :frowning:

Hope I had provided enough information, and, again, thank you!

Did you set the mail log level to debug or only the general log?

Hi @kolaente, sorry for the late reply.

No, I enabled only the app logs since I was not aware of the email logs* :frowning:
I will try this soon as possible and will share the results.

Thank you very much!

Hi, thank you for waiting. The configuration was correct, but my cloud provider was blocking the outbound SMTP traffic. Sorry and, again, thanks!