Getting error when sending an E-Mail

I noticed today that Vikunja no longer sends me emails. However, Vikunja used to send me emails.

This is what my environment-variables look like in my docker-compose.yml


When I try on the web interface to get me an email. I get this error message

ERROR :arrow_forward: mail/func1 18a2 Error during connect to smtp server: %s EOF

With the CLI command I get this error:

No config file found, using default or config from environment variables.
INFO :arrow_forward: cmd/func10 002 Sending testmail…
ERROR :arrow_forward: cmd/func10 003 Error sending test mail: dial failed: EOF

I have already tried a few things that I have seen here in this forum. Among them would be the authtype.

The server should reach the mail server. Other applications can send mail without problems.

Hope this helps. Like Vikunja very much and bought the stickers about two weeks ago :smiley:

This sounds a little like this thread:

What mail server / service are you using to send mails?

Have also seen this post. Tried everything that was mentioned there.

I do not host the mail server myself. I use an offer from a swiss fimra called Infomaniak.

As mentioned above, sending e-mails used to work. I will download an older version of my docker-compose.yml from a backup. I may have triggered the error by making a change.

Edit: I have not seen any difference in the environment variables. Doesn’t look like that would be the problem.

With API version ‘0.18.1’ I can now send email again.


Config File “config” Not Found in “[/app/vikunja /etc/vikunja /root/.config/vikunja]”
Using default config.
INFO :arrow_forward: cmd/func12 002 Sending testmail…
INFO :arrow_forward: cmd/func12 003 Testmail successfully sent.

Can you try setting the mailer port to 25 instead of 465?

That worked in my tests with a free mail account on infomaniak.

Worked. Thanks for helping.