Docker deprecation feedback

Hi, just wanted to provide a little feedback on how the docker deprecation was handled, and maybe share my experience in case it helps anyone else who is trying to move.

In the end the migration to the new one went smoothly, although I did panic a bit when my containers didn’t restart after an upgrade! Especially since there seemed to be some indications that the database was being recreated, which would have been a pain. Luckily that was not the case (maybe I misunderstood some messages?) and after migrating the database is definitely intact.

I use dockge for most of my docker deployments (highly recommended), so it was really easy to see the migration message and find the article. If I could make one complaint it would be that it would have been nice to have some forewarning before the upgrade! My own fault for clicking it without checking, but if there was some kind of mailing list to warn about breaking changes like this it would be very welcome.

In the end, I just did the following as recommended:

  • Pointed vikunja/api → vikunja/vikunja
  • Removed vikunja/frontend
  • Moved the VIKUNJA_API_URL from vikunja/frontend into vikunja/vikunja. This was the only frontend option I had specified so it was easy enough.
  • Removed port 3456 entirely and replaced it with port 80 for both API and frontend. When I next logged in, I get an error because 3456 wasn’t found, even though it’s not in the docker-compose.yml anyway. I guess the port number must also be stored somewhere else. But simply changing the number to 80 in the web UI fixed that.
  • I didn’t specify the publicurl option. Not sure yet if that matters. The docs seem to suggest it is involved with sending emails so if that’s broken I will add the option. Just waiting for now as I’m curious to see what happens.

All good in the end. Thanks for having the article ready before pulling the old container :).

Actually it stopped working again moments after this post because I clicked upgrade again haha. Afterward, it started looking for port 3456 again even though that wasn’t specified anywhere in the dockercompose file. So I now have port 80 mapped to 3456 and it’s happy again.

Glad it all worked for you!

Which messages did you get?

We announce all updates via the newsletter and the blog which also has an rss feed. And on all the social media platforms we’re on.

All emails with links about reminders / password resets etc use that url to build the link to click on. If you don’t provide that variable, none of these links will work.

I didn’t have such luck. It was working fine, now that the update happened it’s just completely borked and I lost all of the data. I’ve tried restarting from scratch but it’s complaining about not finding the API. This is insanely frustrating.

It shouldn’t lose all the data during the upgrade. Does it work if you restore from your last backup?

I wish I got logs during it, but suffice to say I’ve learned a lesson to ensure I set the version from “latest” to a set version number so it can’t just break down like that again on me. While I lost my data and rebuilt the config from scratch to make sure it wasn’t something I did, it still didn’t work. However, it started working the next day. Perhaps it was a DNS issue that gave the API error.

Could someone explain the “docker deprecation?” I don’t see any mention of Vikunja killing off the Docker builds. Was this for a particular release or piece of functionality?

Docker images are not deprecated, there has been a major change in v0.23 changing from two docker containers (frontend and API) to a single one. You can read more in the v0.23 release notes.

1 Like