Why the spaces in the paths?

Hey All

I did try searching for this, but couldn’t find any reasoning. Upon firing on the Docker container, I see the following.

api_1 | 2021/01/11 16:04:00 Config File “config” Not Found in “[/app/vikunja /etc/vikunja /app/vikunja/.config/vikunja]”
api_1 | 2021/01/11 16:04:00 Using default config.

My question is, why are there spaces in the path? i.e.

  1. /app/vikunja /
  2. /etc/vikunja /

Are these accidental errors in the default config on the Container?

That’s not anl real error, I just didn’t figure out a way to check if there are any environment variables present for Vikunja. Because if that’s the case, the error message doesn’t make sense. If you’re using docker, you’re probably configuring it through env variables, shouldn’t be a problem then.

The spaces in the message are all thee locations where Vikunja looks for a config file. (The error message needs better formatting, that’s just the default)

Thanks, I am using docker and specifying the path in an env file.

I didn’t think it was an error - more the fact there are spaces, to be fair, I’m not sure if that is just a bug in the output, or if the filesystem paths actually include a space.

There are no spaces in the path. Those are three paths, see https://vikunja.io/docs/config-options/#config-file-locations
The space between them is the default separation of go when printing a list.
The error itself is coming from the config library, so I don’t really have control over it.

Thanks, I am using docker and specifying the path in an env file.

You mean, you’re configuring Vikunja through env variables? Or do you still have a config file?

Also just a heads up, the Traefik 2 example in the Docs needs a slight adjustment. Its missing the port for the API Container, it requires something like this:

“traefik.http.routers.vikunja-api.loadbalancer.server.port=3456”

1 Like

This should not be necessary. Traefik 2 enters through that port automatically as its the only one exposed by the container.

Here is the relevant part form the traefik2 documentation:

If your setup exposes multiple ports of the api container for some reason you would need to adjust and specify the entry-port manually.

However I personally run Vikunja in a traefik2 setup pretty much equal to the one in the docs with success.

2 Likes

I find it personally better if you define the port in the:
traefik.http.services.<service_name>.loadbalancer.server.port
Both of the comments from @Kelv1n and also from @tojoker94 helped me to found the reason for my bad gateway problem.
I exposed the wrong port from the vikunja-api to traefik2.