Confusing Gmail SMTP error

Hello, I’ve been trying with no success to get Gmail SMTP working. Based on the official support page here I tried port 465 but get an EOF error. Using port 587 and an App Password I get “cmd/func10 002 Error sending test mail: dial failed: SMTP AUTH failed: unexpected server response: 2.7.0 Accepted” which is very confusing. Based on this thread I switched to port 25 but I get an i/o timeout error. I can successfully ping the server on 25 which makes me think my ISP is filtering SMTP traffic. Have other users had success with gmail? Could you share your working configs?

Did you set a gmail app password for less secure apps?

There’s another thread about this with a few more details here: No notification by email - #7 by zarevskaya

Yes I did, and in the App Passwords settings under my Google account it shows that the password I set up for Vikunja was “Last used” today when I was using the testmail command, but the command still returns the above error.

Figured it out! I removed VIKUNJA_MAILER_AUTHTYPE: login from my config file and it worked.

1 Like