Avatar Returns failed with status 500

Running Vikunja in a Docker Container using the default docker-compose yaml.
Everything works fine its just when I try to upload my own avatar it fails and returns:

Request failed with status code 500
Internal Server Error

There was apperantly some issues with this but was supposed to be solved it seems to not be. To add I have tried both jpeg and png.

I do not know if this should be a bug or support topic but I may have somethign set up wrong, I await your help fellow vikunja users.

Anything in the api logs?

Hi @kolaente ! Thanks for your help with this :slight_smile:
I too just spun up Vikunja and encounter the same error, I do have SSO with Authentik set up and accessing Vikunja through HAProxy (through the localhost IP, port 80)

vikunja-proxy-1     | 2022/09/05 23:33:15 [warn] 24#24: *52 a client request body is buffered to a temporary file /var/cache/nginx/client_temp/0000000002, client: [IP], server: , request: "PUT /api/v1/user/settings/avatar/upload HTTP/1.1", host: "[myvikunjaurl]"
vikunja-api-1       | 2022-09-05T23:33:16.320129559Z: ERROR	▶ v1/UploadAvatar 19e open files/3: permission denied
vikunja-api-1       | 2022-09-05T23:33:16.320648899Z: WEB 	▶ [my-ip]  PUT 500 /api/v1/user/settings/avatar/upload 657.140916ms - Mozilla/5.0 (X11; Linux x86_64; rv:104.0) Gecko/20100101 Firefox/104.0
vikunja-proxy-1     | [SERVERIP] - - [05/Sep/2022:23:33:16 +0000] "PUT /api/v1/user/settings/avatar/upload HTTP/1.1" 500 36 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:104.0) Gecko/20100101 Firefox/104.0" "[my-IP]"

Fixed it by adding 1000:1000 to the ./files within container
Might be different for you, @Alexandru, but would recommend reading the thread below:

What I did to fix:

docker exec -it vikunja-api-1 sh (will be the name of the api container)
chown 1000:1000 /app/vikunja/files -R


Thank you so much that fixed it and it makes sense now why I was getting the error :sweat_smile: .