Account creation errors with status code 405

So I have used the docker run command to install the docker frontend, and whenever I try to create an account, then I get the error request failed with status code 405. any idea as to what I did wrong? I ran it with the command:
docker run -d -p 3675:80 vikunja/frontend
I get this error:

Edit: I tried it with the “no proxy docker-compose setup” here, and still get the same error, plus the database logs this error:
2022-09-02 21:38:14 198 [Warning] Access denied for user 'vikunja'@'' (using password: YES)

What’s in the api logs? Is the api running and working correctly?

checking the api logs, it seems to be properly running (I think)

so it does seem to be working properly. the environmental variables should be properly should be properly configured, the docker-compose file I used to set it up:

version: '3'                                                                                                                                         
    image: mariadb:10                                                                                                                                
    command: --character-set-server=utf8mb4 --collation-server=utf8mb4_unicode_ci                                                                    
      MYSQL_ROOT_PASSWORD: <root password>                                                                                                                  
      MYSQL_USER: vikunja                                                                                                                            
      MYSQL_PASSWORD: vikunja                                                                                                                         
      MYSQL_DATABASE: vikunja                                                                                                                        
      - ./db:/var/lib/mysql                                                                                                                          
    restart: unless-stopped                                                                                                                          
    image: vikunja/api                                                                                                                               
      VIKUNJA_DATABASE_HOST: db                                                                                                                      
      VIKUNJA_DATABASE_PASSWORD: vikunja                                                                                                             
      VIKUNJA_DATABASE_TYPE: mysql                                                                                                                   
      VIKUNJA_DATABASE_USER: vikunja                                                                                                                 
      VIKUNJA_DATABASE_DATABASE: vikunja                                                                                                             
      VIKUNJA_SERVICE_JWTSECRET: <random letters/numbers>                                                                                      
      VIKUNJA_SERVICE_FRONTENDURL: http://<ip>:3675/                                                                                       
      - 3456:3456                                                                                                                                    
      - ./files:/app/vikunja/files                                                                                                                   
      - db                                                                                                                                           
    restart: unless-stopped                                                                                                                          
    image: vikunja/frontend                                                                                                                          
      - 3675:80                                                                                                                                      
      VIKUNJA_API_URL: http://<ip>:3456/api/v1                                                                                             
    restart: unless-stopped

where the items in <> are replaced with their actual values
it does appear that maria db is trying to run the version for ubuntu, rather than Debian which I am using, could that be the cause, if so, what would be the fix? as far as I know, it should auto-pull the correct architecture, so that shouldn’t be the problem (I am using arm64)

Can you reach the api at http://<ip>:3456/api/v1/info?

The host os should not matter, it’s docker after all. You can check if you can get a mariadb container working on its own or use a different image (for example the one from
If that still won’t work I’d try postgres instead.

I can reach the api at the url

installing a separate installation of maria, it seems to be working properly

I found the solution, It seems that by default the “using installation at:” was using the frontend port by default, and simply changing it to use the api port instead worked

1 Like