Time format selection

Hello. In my country default time format is 24h, not 12h as it is presented when English language selected. So it is very uncomfortable for me that each time is displayed in this format. I saw that when you switch language to Deutsch then every time is shown in 24h format, but if you don’t know Deutsch, it’s not a good solution.

My suggestion is to add to the settings the option to choose the 12h / 24h time format.

1 Like

Hmmm the time format should depend on the locale set in your browser, not on the language you configured. But I think it would make sense to have a separate setting for this.


My language is Polish. I checked it on Firefox, Chrome and Edge, but they all show in 12h format. So maybe the error only applies to the Polish language?

Ok, everything works as you wrote. I just used “image: vikunja/api:latest” and “image: vikunja/frontend:latest” instead of “image: vikunja/api:unstable” and “image: vikunja/frontend:unstable”. I’m sorry for the trouble.

Glad you found a solution! The latest docker images contain the latest release, so if the bug was present in the unstable release but not in the last release, we may have introduced a bug since the last release. I’ll take another look but please report again if the problem arises again after the next stable release.

After adding Polish to Vikunja, the problem came back. When English is set in Vikunja settings, the hours are displayed in 24h format. However, if I set the Polish language, then hours are displayed in 12h format. I have checked other languages and format is:

12h format:

24h format:
DE, EN, FR, PT, swiss, VN, RU

So the time format definitely depends on the language you choose. It would be good if the Polish language setting also displayed the 24h format.

Also I see the same problem with the dates display:

14 Feb 2022

Feb 14, 2022

In the Polish language it should be also as in English (14 Feb 2022).

1 Like

huh that’s kind of wired. I think the best way to solve this really is a setting for the time format.

I think so too. That would solve the problem.